Fluidsynth - What's the deal with Fluidsynth?

I enjoy SS14, However, I am cursed with being a Linux user. For too long have I sat in the bar in complete silence whilst everyone else is jamming out to the musician playing theme songs to children’s shows on the bar piano.

I’ve attempted to install FluidSynth, However, without any available instructions and it’s difficult to understand how to get the software functioning, much less functioning with the game’s MIDI instruments. I’ve done some searching through the forums, and have only found This Post, which really doesn’t give that much information. Is there a guide somewhere that i’m missing? Does it still have yet to be fixed?

 

Some more detail on what particular distro you are using is helpful. I personally had to create symlink, as game expects “libfluidsynth.so” file specifically and it is likely to be absent.

https://github.com/space-wizards/space-station-14/pull/10453

Thank you for linking that! Also, I’ve tried the symlink method, but it didn’t quite work. I have very minimal computer knowledge so I’ll check back and see if I simply made a mistake in the terminal.

Also, i use Mint 20.3 Cinnamon.

I’m on Debian-based MX, so our systems are probably somewhat similar. If I remember correctly, I first tried installing a package named fluidsynth, but that didn’t do it, so I installed libfluidsynth-dev and that did the trick. I can see that I also have:

fluid-soundfont-gm
fluid-soundfont-gs
libfluidsynth2
libfluidsynth3

Not sure if any of these is necessary at all. Also, some of those packages are coming from the MX repo, not Debian’s, so they’re probably more up to date.

If all that fails, it’s possible that upgrading to Mint 21 will give you more up to date packages.

I think you may be correct about upgrading to Mint 21, and seeing as Mint is based off of both Debian and Ubuntu, I’ll see if I can get those packages to install. I’ve got a busy ass week this week but this weekend I’m gonna buckle down and see if I can get this stuff to work. If I’m successful perhaps I’ll make a forum post explaining what I did for anyone else that may share my problems with the software!

Please let us know whichever way it goes!

Installing libfluidsynth-dev helped in my case.